您的位置:首页 > 其它

POJ 1328 Radar Installation

2016-07-23 16:31 239 查看
Radar Installation

Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%lld & %llu

Submit

Status

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.

Sample Input

3 2

1 2

-3 1

2 1

1 2

0 2

0 0

Sample Output

Case 1: 2

Case 2: 1

题意:有一条x轴,上边是海洋下边是陆地,给出海洋中岛屿的位置,和陆地雷达的范围,求最少多少个雷达可以把岛屿全部笼罩, 不能全部笼罩输出-1

题解:先考虑-1 的情况,y>d || d<=0 || y<0时为-1;再求出每个岛屿的可以与海岸线连接的x轴坐标,对左坐标从小到大排序,然后比较前一个右坐标与后一个左坐标的大小(此处有个坑);

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;

struct yuan
{
double zuo;
double you;
};
struct yuan e[1005];

bool cmp(yuan q,yuan p)
{
return q.zuo<p.zuo;
}

int main()
{
int n,d,i,j,ans;
double x,y,end;
j=1;
while(scanf("%d%d",&n,&d)!=EOF)
{
if(n==0&&d==0)  break;
for(i=0;i<n;i++)
{
scanf("%lf%lf",&x,&y);
e[i].zuo=x-sqrt(d*d-y*y);
e[i].you=x+sqrt(d*d-y*y);
}
if(y>d||d<=0||y<0)  ans=-1;
else
{
sort(e,e+n,cmp);
end=e[0].you;
ans=1;
for(i=1;i<n;i++)
{
if(e[i].zuo>end)
{
ans++;
end=e[i].you;
}
else if(e[i].you<end)//注意这个坑,当前一个的圆或许包含在第二个的圆,那么也要替换
{
end=e[i].you;
}
}
}
printf("Case %d: %d\n",j,ans);
j++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: