您的位置:首页 > 其它

poj----1338

2016-07-23 15:33 295 查看
Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 

1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ... 

shows the first 10 ugly numbers. By convention, 1 is included. 

Given the integer n,write a program to find and print the n'th ugly number. 

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0


Sample Output

1
2
10

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<iostream>
#include<algorithm>

using namespace std;

#define N 1509
int f
;
int main()
{
int a2,a3,a5,i,tmp,n;
a2=a3=a5=1;
f[1]=1;
for(i=2; i<N; i++)
{
tmp=min(f[a2]*2,f[a3]*3);
tmp=min(tmp,f[a5]*5);
f[i]=tmp;
if(tmp==f[a2]*2)
++a2;
if(tmp==f[a3]*3)
++a3;
if(tmp==f[a5]*5)
++a5;

}
while(scanf("%d",&n)!=EOF)
{
if(n==0)
break;

printf("%d\n", f
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: