您的位置:首页 > 其它

【HDU】2824 - GCD(欧拉函数打表)

2016-07-23 15:26 253 查看
点击打开题目


The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5451    Accepted Submission(s): 2307


Problem Description

The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose
you are given a, b, try to calculate (a)+ (a+1)+....+ (b)

 

Input

There are several test cases. Each line has two integers a, b (2<a<b<3000000).

 

Output

Output the result of (a)+ (a+1)+....+ (b)

 

Sample Input

3 100

 

Sample Output

3042

 

Source

2009 Multi-University Training Contest 1 - Host
by TJU

 

打一个 1 到 MAX 的欧拉函数表,表示 1 加到 i 的欧拉函数值。

代码如下:

#include <cstdio>
#define MAX 3000000
__int64 eu[MAX+5];
void Eular()
{
eu[1] = 1;
for (int i = 2 ; i <= MAX ; i++)
{
if (!eu[i])
{
for (int j = i ; j <= MAX ; j += i)
{
if (!eu[j])
eu[j] = j;
eu[j] -= eu[j] / i;
}
}
eu[i] += eu[i-1];
}
}
int main()
{
Eular();
int a,b;
while (~scanf ("%d %d",&a,&b))
printf ("%I64d\n",eu[b] - eu[a-1]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: