您的位置:首页 > 其它

HDU Problem - 5363 Key Set 【快速幂】

2016-07-23 14:45 260 查看

Key Set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1763    Accepted Submission(s): 928

[align=left]Problem Description[/align]
soda has a set S
with n
integers {1,2,…,n}.
A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of
S
are key set.
 

[align=left]Input[/align]
There are multiple test cases. The first line of input contains an integer
T
(1≤T≤105),
indicating the number of test cases. For each test case:

The first line contains an integer n
(1≤n≤109),
the number of integers in the set.
 

[align=left]Output[/align]
For each test case, output the number of key sets modulo 1000000007.
 

[align=left]Sample Input[/align]

4
1
2
3
4

 

[align=left]Sample Output[/align]

0
1
3
7

 
对于一个有n的元素的集合,组成的非空子集有2^n - 1个,其中和为奇数的个数比和为偶数的个数多一个。注意利用快速幂函数,不要超过了long long。
#include <stdio.h>
__int64 pow(__int64 x, __int64 y) {
__int64 res = 1;
__int64 base = x;
y -= 1;
while (y) {
if (y&1) res = base*res%1000000007;
base = base*base%1000000007;
y >>= 1;
}
return res;
}
int main() {
int t;
__int64 n;
scanf("%d", &t);
while (t--) {
scanf("%I64d", &n);
printf("%I64d\n", pow(2, n) - 1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 杭电