您的位置:首页 > 运维架构

【POJ 3641】Pseudoprime numbers

2016-07-23 13:57 477 查看
Pseudoprime numbers

Description

Fermat’s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing “0 0”. Each test case consists of a line containing p and a.

Output

For each test case, output “yes” if p is a base-a pseudoprime; otherwise output “no”.

Sample Input

3 2

10 3

341 2

341 3

1105 2

1105 3

0 0

Sample Output

no

no

yes

no

yes

yes

刚开始想用素数打表判断素数,发现行不通,就单独判断每个数是不是素数,在快速幂;

#include<stdio.h>
#include<string.h>
long long quickcmp(long long i,long long j,long long k)
{
long long sum=1,base=i;
while(j)
{
if(j&1)
{
sum=sum*base%k;
}
base=(base%k*base%k)%k;
j>>=1;
}
return sum;
}
int prime(long long a )
{
int i;
if(a==2)
return 1;
for(i=2;i*i<=a;i++)
if(a%i==0)
return 0;
return 1;
}
int main()
{
long long p,a;
while(scanf("%lld%lld",&p,&a)!=EOF&&(a||p))
{
if(prime(p))
printf("no\n");
else
{
if(quickcmp(a,p,p)==a)
printf("yes\n");
else
printf("no\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 快速幂