您的位置:首页 > 其它

HDU 4445 ——Crazy Tank(数学题,暴力枚举)

2016-07-23 13:18 435 查看
Crazy Tank
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u
Submit Status

Description

Crazy Tank was a famous game about ten years ago. Every child liked it. Time flies, children grow up, but the memory of happy childhood will never go. 



Now you’re controlling the tank Laotu on a platform which is H meters above the ground. Laotu is so old that you can only choose a shoot angle(all the angle is available) before game start and then any adjusting is not allowed. You need to
launch N cannonballs and you know that the i-th cannonball’s initial speed is Vi. 

On the right side of Laotu There is an enemy tank on the ground with coordination(L1, R1) and a friendly tank with coordination(L2, R2). A cannonball is considered hitting enemy tank if it lands on the ground between [L1,R1] (two ends are included). As the
same reason, it will be considered hitting friendly tank if it lands between [L2, R2]. Laotu's horizontal coordination is 0. 

The goal of the game is to maximize the number of cannonballs which hit the enemy tank under the condition that no cannonball hits friendly tank. 

The g equals to 9.8.
 

Input

There are multiple test case. 

Each test case contains 3 lines. 

The first line contains an integer N(0≤N≤200), indicating the number of cannonballs to be launched. 

The second line contains 5 float number H(1≤H≤100000), L1, R1(0<L1<R1<100000) and L2, R2(0<L2<R2<100000). Indicating the height of the platform, the enemy tank coordinate and the friendly tank coordinate. Two tanks may overlap

The third line contains N float number. The i-th number indicates the initial speed of i-th cannonball. 

The input ends with N=0.
 

Output

For each test case, you should output an integer in a single line which indicates the max number of cannonballs hit the enemy tank under the condition that no cannonball hits friendly tank.
 

Sample Input

2
10 10 15 30 35
10.0
20.0
2
10 35 40 2 30
10.0
20.0
0

 

Sample Output

1
0

Hint

In the first case one of the best choices is that shoot the cannonballs parallelly to the horizontal line, then the first cannonball lands on 14.3 and the second lands on 28.6. In the second there is no shoot angle to make any cannonball land between [35,40] on the condition that no cannonball lands between [2,30].

 

题目:有n个子弹,一辆敌军坦克,一辆友军坦克。每颗子弹都不同的速度,问在不打到友军的情况下,用什么角度发射炮弹打到的敌军最多。

思路:暴力枚举角度求最大值

#include <cmath>
#include <cstring>
#include <cstdio>
#include <vector>
#include <string>
#include <algorithm>
#include <string>
#include <map>
#include <set>

using namespace std;

#define MAXN 200010
#define LEN 1000000
#define INF 1e9+7
#define MODE 1000000
#define pi acos(-1)
#define g 9.8
typedef long long ll;

int n;
double h,l1,r1,l2,r2;
double v[MAXN];

int solve(double a)
{
int cnt=0;
for(int i=0;i<n;i++){
double t=(sqrt(v[i]*v[i]*sin(a)*sin(a)+2*g*h)+v[i]*sin(a))/g;
double x=v[i]*cos(a)*t;
if(x>=l2&&x<=r2)
{
return 0;
}
if(x>=l1&&x<=r1)
cnt++;
}
return cnt;
}

int main()
{
while(scanf("%d",&n))
{
if(n==0)
break;
scanf("%lf%lf%lf%lf%lf",&h,&l1,&r1,&l2,&r2);
for(int i=0;i<n;i++)
scanf("%lf",v+i);
int maxn=0;
for(double i=-pi/2;i<=pi/2;i+=pi/1000)
{
maxn=max(solve(i),maxn);
}
printf("%d\n",maxn);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: