您的位置:首页 > 其它

HDOJ 5363 Key Set

2016-07-23 11:40 239 查看

Key Set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1713    Accepted Submission(s): 905


[align=left]Problem Description[/align]
soda has a set S
with n
integers {1,2,…,n}.
A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of
S
are key set.
 

[align=left]Input[/align]
There are multiple test cases. The first line of input contains an integer
T
(1≤T≤105),
indicating the number of test cases. For each test case:

The first line contains an integer n
(1≤n≤109),
the number of integers in the set.
 

[align=left]Output[/align]
For each test case, output the number of key sets modulo 1000000007.
 

[align=left]Sample Input[/align]

4
1
2
3
4

 

[align=left]Sample Output[/align]

0
1
3
7

 

[align=left]Author[/align]
zimpha@zju
 

[align=left]Source[/align]
2015 Multi-University Training Contest 6

 

找啊找啊找规律

规律是an=2^(n-1)-1

#include<stdio.h>
#include<string.h>
#define Mod 1000000007
__int64 qp(__int64 n,__int64 m)
{
__int64 ans=1;
while(m)
{
if(m&1)
ans=ans*n%Mod;
n=n*n%Mod;
m>>=1;
}
return ans;
}
int main()
{
__int64 n,T;
scanf("%I64d",&T);
while(T--)
{
scanf("%I64d",&n);
printf("%I64d\n",qp(2,n-1)-1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: