您的位置:首页 > 其它

poj 2105 大数

2016-07-23 08:59 316 查看
IP Address

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 19666 Accepted: 11366
Description

Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at
a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary
systems are: 
27   26  25  24  23   22  21  20

128 64  32  16  8   4   2   1


Input

The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.
Output

The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.
Sample Input
4
00000000000000000000000000000000
00000011100000001111111111111111
11001011100001001110010110000000
01010000000100000000000000000001

Sample Output
0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1


就是每八位二进制数数字变成一个整数

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

char str[40];

int pow(int x,int y)
{
int ans=2;
for(int i=1;i<y;i++)
ans*=2;
if(y==0)
ans=1;
return ans;
}

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int a=0,b=0,c=0,d=0;
scanf("%s",str);
for(int i=7;i>=0;i--)
if(str[i]=='1')
a+=pow(2,7-i);
for(int i=15;i>=8;i--)
if(str[i]=='1')
b+=pow(2,15-i);
for(int i=23;i>=16;i--)
if(str[i]=='1')
c+=pow(2,23-i);
for(int i=31;i>=24;i--)
if(str[i]=='1')
d+=pow(2,31-i);
printf("%d.%d.%d.%d\n",a,b,c,d);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: