您的位置:首页 > 其它

2016ACM暑假集训 - Prime Ring Problem

2016-07-22 23:46 246 查看
Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8


Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2


解题思路:深度优先搜索,固定第一个为1,后面的为2-n,如果不符合条件救回溯。另外用一个数组储存是否是素数,加快速度

代码:

#include <cstdio>
#include <cmath>
#include <cstring>
int a[25];
bool use[25];
int n;

bool p[] = {0, 0, 1, 1, 0, 1,
0, 1, 0, 0, 0,
1, 0, 1, 0, 0,
0, 1, 0, 1, 0,
0, 0, 1, 0, 0,
0, 0, 0, 1, 0,
1, 0, 0, 0, 0,
0, 1, 0};

void DFS(int num)
{
if(n == num && p[1+a[n-1]])
{
for(int i = 0; i < n; i++)
{
printf(i == n-1 ? "%d\n" : "%d ", a[i]);
}
}
else
{
for(int i = 2; i <= n; i++)
{
if(!use[i] && p[i+a[num-1]])
{
a[num] = i;
use[i] = true;
DFS(num+1);
use[i] = false;
}
}
}
}

int main()
{
int t = 0;
while(scanf("%d",&n) != EOF)
{
memset(use, 0, sizeof(use));
a[0] = 1;
t++;
printf("Case %d:\n", t);
DFS(1);
puts("");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM DFS