您的位置:首页 > 其它

COURSES(裸二部图最大匹配)

2016-07-22 20:38 281 查看
COURSES

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 20967 Accepted: 8249

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

every student in the committee represents a different course (a student can represent a course if he/she visits that course)

each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N

Count1 Student1 1 Student1 2 … Student1 Count1

Count2 Student2 1 Student2 2 … Student2 Count2



CountP StudentP 1 StudentP 2 … StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on the standard output. For each input data set the program prints on a single line “YES” if it is possible to form a committee and “NO” otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2

3 3

3 1 2 3

2 1 2

1 1

3 3

2 1 3

2 1 3

1 1

Sample Output

YES

NO

Source

Southeastern Europe 2000

分析:

本题就是求最大匹配问题,当匹配数等于课程数是YES,否则NO。直接用匈牙利-DFS模板即可。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

const int maxn=310;
int g[maxn][maxn];
int cx[maxn],cy[maxn];
int mk[maxn];
int nx,ny;

int path(int u)//求增广路,每次只能使匹配数加一
{
for(int v=1;v<=ny;v++)
{
if(g[u][v] && !mk[v])//找到一条没有匹配的边
{
mk[v]=1;
if(cy[v]==-1 || path(cy[v]))//若找到一条两端都没有匹配的边则已找到。注意前面的条件满足时将不会进行递归
{
cx[u]=v;//更新匹配,原匹配已被覆盖
cy[v]=u;
return 1;
}
}
}
return 0;
}

int MaxMatch()
{
int res=0;
memset(cx,-1,sizeof(cx));
memset(cy,-1,sizeof(cy));
for(int i=1;i<=nx;i++)//每次找x中没有被覆盖的点
{
if(cx[i]==-1)
{
memset(mk,0,sizeof(mk));
res+=path(i);
}
}
return res;
}

int main()
{
//freopen("in.txt","r",stdin);
int t,num;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&nx,&ny);
memset(g,0,sizeof(g));
int v;
for(int i=1;i<=nx;i++)
{
scanf("%d",&num);
for(int j=0;j<num;j++)
{
scanf("%d",&v);
g[i][v]=1;
}
}
if(MaxMatch()==nx)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: