您的位置:首页 > 其它

(POJ1325)Machine Schedule(二部图最大匹配)

2016-07-22 20:35 483 查看
Machine Schedule

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 14069 Accepted: 6022

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine’s working mode from time to time, but unfortunately, the machine’s working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10

0 1 1

1 1 2

2 1 3

3 1 4

4 2 1

5 2 2

6 2 3

7 2 4

8 3 3

9 4 3

0

Sample Output

3

Source

Beijing 2002

分析:

将机器A和机器B看做连个集合,在两个集合可以等效工作的两个模式间建边,即可形成一个二部图。本题是求最小点覆盖集问题。由于二部图的点覆盖数=匹配数。所以就转换成了求最大匹配的问题。直接用匈牙利算法-DFS的模板即可。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

const int maxn=110;
int nx,ny;
int g[maxn][maxn];
int cx[maxn],cy[maxn];
int mk[maxn];

int path(int u)//求增广路,每次只能使匹配数加一
{
for(int v=1;v<=ny;v++)
{
if(g[u][v] && !mk[v])//找到一条没有匹配的边
{
mk[v]=1;
if(cy[v]==-1 || path(cy[v]))//若找到一条两端都没有匹配的边则已找到。注意前面的条件满足时将不会进行递归
{
cx[u]=v;//更新匹配,原匹配已被覆盖
cy[v]=u;
return 1;
}
}
}
return 0;
}

int MaxMatch()
{
int res=0;
memset(cx,-1,sizeof(cx));
memset(cy,-1,sizeof(cy));
for(int i=1;i<=nx;i++)//每次找x中没有被覆盖的点
{
if(cx[i]==-1)
{
memset(mk,0,sizeof(mk));
res+=path(i);
}
}
return res;
}

int main()
{
//freopen("in.txt","r",stdin);
int k;
while(scanf("%d",&nx)!=EOF)
{
if(!nx) break;
scanf("%d%d",&ny,&k);
memset(g,0,sizeof(g));
int m,u,v;
for(int i=0;i<k;i++)
{
scanf("%d%d%d",&m,&u,&v);
g[u][v]=1;
}
printf("%d\n",MaxMatch());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: