您的位置:首页 > 大数据 > 人工智能

Doing Homework again hd 17892

2016-07-22 20:29 393 查看
Description

zichen has just come back school from the 30th ACM/ ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If zichen hands in the homework after the deadline, the teacher will reduce his score of the final test.
And now we assume that doing everyone homework always takes one day. So zichen wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3

3

3 3 3

10 5 1

3

1 3 1

6 2 3

7

1 4 6 4 2 4 3

3 2 1 7 6 5 4

Sample Output

0

3
5

#include<stdio.h>
#include<algorithm>
using namespace std;
struct node
{
int t;
int f;
bool y;
}k[1100];
int cmp(node x,node y)
{
if(x.t!=y.t)
return x.t<y.t;
return x.f>y.f;
}
int main()
{
int n,i,a,j;
scanf("%d",&n);
while(n--)
{
scanf("%d",&a);
for(i=0;i<a;i++)
scanf("%d",&k[i].t);
for(i=0;i<a;i++)
{
scanf("%d",&k[i].f);
}
for(i=0;i<a;i++)
k[i].y=true;
int l;
int sum;
int p1,p2;
sum=0;
l=1;
sort(k,k+a,cmp);
for(i=0	;i<a;i++)
{
if(k[i].t>=l)
{
l++;
continue;
}
p1=k[i].f;p2=i;
for(j=0;j<i;j++)
{
if(k[j].f<p1&&k[j].y)
{
p1=k[j].f;
p2=j;
}
}
sum+=p1;
k[p2].y=false;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: