您的位置:首页 > 其它

POJ-1328 Radar Installation

2016-07-22 20:28 246 查看
G - Radar Installation
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%lld & %llu
Submit Status

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the
sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 



Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing
two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0


Sample Output

Case 1: 2
Case 2: 1

AC代码:
#include <stdio.h>
#include <math.h>
#include <algorithm>
using namespace std;
#define G 1011
struct node
{
double l,r;  //当小岛被覆盖时,雷达活动的区间
}a[G];
bool cmp(node A,node B)
{
if(A.r!=B.r)
return A.r<B.r;
else
return A.l>B.l;
}
int main()
{
int n,d,i,x,y,flag,count;
int k=1;
double temp;
while(scanf("%d%d",&n,&d))
{
if(n==0&&d==0) break;
flag=0;                 //标记是否有小岛无法被覆盖
for(i=0;i<n;++i)
{
scanf("%d%d",&x,&y);
if(y>d)
{
flag=1;         //如果雷达不足以覆盖,则标记
continue;
}
temp=sqrt(d*d*1.0-y*y);
a[i].l=x-temp;
a[i].r=x+temp;
}
printf("Case %d: ",k++);
if(flag)
{
printf("-1\n");
continue;
}
sort(a,a+n,cmp);
count = 1;
temp=a[0].r;
for(i=1;i<n;++i)
{
if(a[i].l>temp)
{
temp=a[i].r;
count++;
}
}
printf("%d\n",count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: