您的位置:首页 > 其它

HDU 1213 How Many Tables(并查集)

2016-07-22 18:57 471 查看
Y - How Many Tables
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u
Submit Status

Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 

 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases. 

 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 

 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

 

Sample Output

2
4

题意:有n个朋友参加小明的生日,但只有互相认识的朋友才能坐在一张桌子上 ,已知如果A和B认识,B和C认识,那么A和C也认识,给出已经互相认识的人的编号,球做少需要几张桌子。

首先用并查集连接已经互相认识的人,然后搜索即可。

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int p[1005],flag[1004];
int find(int k);
int main()
{
int n,i,j,k,sum,t,x,y,t1,t2,m;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
fill(p,p+n+1,-1);
memset(flag,0,sizeof(flag));
for(i=1;i<=m;i++)
{
scanf("%d%d",&x,&y);
t1=find(x);
t2=find(y);
if(t1!=t2)
p[t1]=t2;
}
sum=0;
for(i=1;i<=n;i++)
{
if(!flag[i])
{
t1=find(i);
if(!flag[t1])
{
flag[t1]=1;
sum+=1;
}
flag[i]=1;
}
}
printf("%d\n",sum);
}
return 0;
}
int find(int k)
{
if(p[k]==-1)
return k;
flag[k]=1;
return find(p[k]);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: