您的位置:首页 > 其它

hdu 5578 Friendship of Frog【水题】

2016-07-22 18:27 537 查看

Friendship of Frog

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 909    Accepted Submission(s): 570


Problem Description

N frogs from different countries are standing in a line. Each country is represented by a lowercase letter. The distance between adjacent frogs (e.g. the 1st and the 2ndfrog, the N−1th and the Nth frog, etc) are exactly 1. Two frogs are friends if they come
from the same country.

The closest friends are a pair of friends with the minimum distance. Help us find that distance.

 

 

Input

First line contains an integer T, which indicates the number of test cases.

Every test case only contains a string with length N, and the ith character of the string indicates the country of ith frogs.

⋅ 1≤T≤50.

⋅ for 80% data, 1≤N≤100.

⋅ for 100% data, 1≤N≤1000.

⋅ the string only contains lowercase letters.

 

 

Output

For every test case, you should output "Case #x: y", where x indicates the case number and counts from 1 and y is the result. If there are no frogs in same country, output −1 instead.

 

 

Sample Input

2

abcecba

abc

 

 

Sample Output

Case #1: 2

Case #2: -1

 

 

Source

2015ACM/ICPC亚洲区上海站-重现赛(感谢华东理工)

 

 题目大意:找两个相同字母最近的距离。

Ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
char a[5000000];
int main()
{
int t;
int kase=0;
scanf("%d",&t);
while(t--)
{
scanf("%s",&a);
int n=strlen(a);
int output=0x3f3f3f3f;
for(int i=0;i<n;i++)
{
for(int j=i+1;j<n;j++)
{
if(a[i]==a[j])
{
output=min(output,(j-i));
break;
}
}
}
if(output!=0x3f3f3f3f)
printf("Case #%d: %d\n",++kase,output);
else printf("Case #%d: -1\n",++kase);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 5578