您的位置:首页 > 大数据 > 人工智能

HDU(2124)Repair the Wall补墙,贪心

2016-07-22 17:03 471 查看
Repair the Wall
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u
Submit Status

Description

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon. 

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood. 

One day, Kitty found that there was a crack in the wall. The shape of the crack is 

a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors. 

The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired
perfectly, without any gap. 

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ? 

 

Input

The problem contains many test cases, please process to the end of file( EOF ). 

Each test case contains two lines. 

In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which 

mentioned above. 

In the second line, there are N positive integers. The i th integer Ai(0<Ai<1000000000 ) means that the i th block has the size of 1×Ai (in inch). 

 

Output

For each test case , print an integer which represents the minimal number of blocks are needed. 

If Kitty could not repair the wall, just print "impossible" instead. 

 

Sample Input

5 3
3 2 1
5 2
2 1

 

Sample Output

2
impossible
题目大意:
给出n,m;n为补墙供需多少砖,m给你m堆砖,要把墙补好,最少使用多少堆砖
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
__int64 a[1000];
bool cmp(__int64 a,__int64 b)//注意整型范围
{
return a>b;
}
int main()
{
__int64 n,m,sum,ans,i;
while(scanf("%I64d%I64d",&n,&m)!=EOF)
{  sum=0;
ans=0;
for(i=0; i<m; i++)
scanf("%I64d",&a[i]);
sort(a,a+m,cmp);
for(i=0; i<m; i++)
sum+=a[i];
if(sum<n)
{
printf("impossible\n");
continue;
}
else
{
for(i=0; i<m; i++)
{
if(n>=a[i])
{  ans++;
n=n-a[i];
}
else
{
if(n!=0)
ans++;
break;
}  }  }
printf("%I64d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: