您的位置:首页 > 其它

HDU 1009 FatMouse' Trade (贪心)

2016-07-22 16:35 357 查看

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 66476    Accepted Submission(s): 22593


[align=left]Problem Description[/align]
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

[align=left]Input[/align]
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case
is followed by two -1's. All integers are not greater than 1000.

 

[align=left]Output[/align]
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

[align=left]Sample Input[/align]

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

 

[align=left]Sample Output[/align]

13.333
31.500

 

[align=left]Author[/align]
CHEN, Yue
 

[align=left]Source[/align]
ZJCPC2004

 

[align=left]Recommend[/align]
JGShining   |   We have carefully selected several similar problems for you:  1008 1050 1005 1051 1010 
 题意:
康康准备了 M 斤的食物, 准备跟舍长交换哲学之宝 
舍长有 N 个房间. 第 i 个房间有 J[i] 的 需要 F[i] 斤的食物. 康康可以不换完整个房间的 ,
他可以用 F[i]* a% 的食物 换 J[i]* a% 的 
现在给你一个实数 M 问你康康最多能获得多少的 
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct node
{
double a,b,c;
}t[11000];
bool cmp(node x,node y)
{
if(x.c==y.c)
return x.a>y.a;
return x.c>y.c;
}
int main()
{
int n,m,i,j,k;
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==-1&&m==-1)
break;
for(i=0;i<m;i++)
{
scanf("%lf%lf",&t[i].a,&t[i].b);
t[i].c=t[i].a/t[i].b;
}
sort(t,t+m,cmp);
double sum=0.0;
for(i=0;i<m;i++)
{
if(n>=t[i].b)
{
sum+=t[i].a;
n=n-t[i].b;
}
else
{
sum+=n*t[i].c;
n=0;
}
}
printf("%.3lf\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: