您的位置:首页 > 大数据 > 人工智能

Doing Homework again

2016-07-22 16:10 507 查看

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11286    Accepted Submission(s): 6621


[align=left]Problem Description[/align]
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce
his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

 

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.

 

[align=left]Output[/align]
For each test case, you should output the smallest total reduced score, one line per test case.

 

[align=left]Sample Input[/align]

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

 

[align=left]Sample Output[/align]

0
3
5问题关键词还是锁定在了学分的身上,我们输出的是最小扣除学分,那么我们就要在有限的时间里边完成最多的高分作业,这个时候我们首先想到了排序.
学分从高到底排序,但这是不够的,还需要把截止时间从小到大排并给每一份作业都预定上做那份作业的时间,预定天数的同时要保证这份作业一定是要价值最高,我们这里就应用了排序的操作,然后就是预定天数的顺序,我们要尽量把作业放在截止的当天去做,能把大量的时间让给重复的作业和之前截止的作业。<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
int b[1100];
using namespace std;
struct stu{
int f,dl;
}a[1100];
bool cmp(stu a,stu b)
{
if(a.f!=b.f)
return a.f>b.f;
return a.dl<b.dl;
}
int main()
{
int t,n,i,s,p;
scanf("%d",&t);
while(t--)
{
memset(b,0,sizeof(b));
s=0;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&a[i].dl);
for(i=0;i<n;i++)
scanf("%d",&a[i].f);
sort(a,a+n,cmp);
for(i=0;i<n;i++)
{
p=a[i].dl;
while(p)
{
if(b[p]==0)
{
b[p]=1;
break;
}
else
p--;
}
if(p==0)
s+=a[i].f;
}
printf("%d\n",s);
}
return 0;
}</span>
 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: