您的位置:首页 > 其它

HDOJ-1009-FatMouse' Trade

2016-07-22 16:09 381 查看
FatMouse’ Trade

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 66473 Accepted Submission(s): 22591

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

Sample Output

13.333

31.500

一个简单的贪心问题。

此题只要注意几个比较坑的数据就行了:

1 0

0 1

1.000

0 1

0.000

4 5

100 5

20 2

30 0

10 0

104.000

只要处理好这几个数字即可。

代码如下:

#include <cstdio>
#include <algorithm>
#include<stdint.h>
#include<math.h>
#include<string.h>
struct q{
double j,f,k;
}p[1005];
bool cmp(q x,q y){
return x.k>y.k;
}
using namespace std;
int main(){
int m,n;
double a;
while(~scanf("%d%d",&m,&n)&&m!=-1||n!=-1){
a=0.0;
if(!n){
printf("%.3f\n",a);
continue;
}
memset(p,0,sizeof(p));
for(int i=0;i<n;i++){
scanf("%lf %lf",&p[i].j,&p[i].f);
if(!p[i].f){
a+=p[i].j;
p[i].j=0;
continue;
}
p[i].k=p[i].j/p[i].f;
}
sort(p,p+n,cmp);
for(int i=0;i<n;i++){
if(p[i].f>m){
a+=p[i].k*m;
break;
}
else {
a+=p[i].j;
m-=p[i].f;
}
}
printf("%.3lf\n",a);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: