您的位置:首页 > 大数据 > 人工智能

hd 1789 Doing Homework again

2016-07-22 15:57 429 查看


Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11278    Accepted Submission(s): 6616


Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final
test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

 

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.

 

Output

For each test case, you should output the smallest total reduced score, one line per test case.

 

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

 

Sample Output

0
3
5

 

 先将分数由大到小排列,如果有分数相同的情况,再将截至日期由小到大排列。然后设出一个数组a[]来按照分数从高到低记录必须占用的日期,如果有空闲的日期则标记为1
,若没有空闲的日期则舍弃这个分数

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct note{
int T;
int S;
}q[1010];
bool cmp(note a , note b)
{
if(a.S != b.S)
return a.S > b.S;
else
return a.T < b.T;
}
int main()
{
int n , t , i , j;
int a[1010];
scanf("%d", &t);
while(t--)
{
scanf("%d", &n);
for(i = 0 ; i < n ; i++)
scanf("%d", &q[i].T);
for(i = 0 ; i < n ; i++)
scanf("%d", &q[i].S);
sort(q,q+n,cmp);
memset(a,0,sizeof(a));
int sum = 0;
for(i = 0 ; i < n ; i++)
{
for(j = q[i].T ; j >= 1 ; j--)
{
if(a[j] == 0)
{
a[j] = 1;
break;
}
}
if(j == 0)
sum += q[i].S;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: