您的位置:首页 > 其它

【HDU-oj]-1009-FatMouse' Trade(贪心)

2016-07-22 15:23 387 查看


FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 66462    Accepted Submission(s): 22584


Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All
integers are not greater than 1000.

 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

 

Sample Output

13.333
31.500

 
B换A
应该把每种情况获得的比例算出来,比例从大到小排序,从前到后依次取就好。

#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
double s1,s2,pj;
}a[100010];
bool cmp(node x,node y)
{
return x.pj>y.pj;
}
int main()
{
double m;
int n;
double sum;
while(~scanf("%lf %d",&m,&n)&&(m!=-1&&n!=-1))
{
sum=0;
for(int i=1;i<=n;i++)
{
scanf("%lf %lf",&a[i].s1,&a[i].s2);
a[i].pj=a[i].s1/a[i].s2;<span style="white-space:pre"> </span>//依次算出比例
}
sort(a+1,a+1+n,cmp);<span style="white-space:pre"> </span>//比例大得到多,所以从大到小排序
for(int i=1;i<=n;i++)
{
if(a[i].s2<=m)
{
sum+=a[i].s1;
m-=a[i].s2;
}
else
{
sum+=(m/a[i].s2)*a[i].s1;
break;
}
}
printf("%.3lf\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: