您的位置:首页 > 其它

HDU 1002 A + B Problem II

2016-07-22 15:23 411 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 315232 Accepted Submission(s): 61142


[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211

[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

[align=left]Author[/align]
Ignatius.L

[b]题解:大数A+B,直接用模板来解决(附上不同的代码)[/b]

#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
int j=1,p=0,i,n,aa,bb;
char a[1000],b[1000],c[1000];
scanf("%d",&n);
while(n)
{
scanf("%s%s",a,b);
printf("Case %d:\n",j++);
printf("%s + %s = ",a,b);
aa=strlen(a)-1;bb=strlen(b)-1;
for( i=0;aa>=0||bb>=0;aa--,bb--,i++)
{
if(aa>=0&&bb>=0)c[i]=a[aa]+b[bb]-'0'+p;
if(aa>=0&&bb<0)c[i]=a[aa]+p;
if(aa<0&&bb>=0)c[i]=b[bb]+p;
if(c[i]>'9'){c[i]=c[i]-10;p=1;}
else p=0;
}
if(p==1)printf("%d",p);
while(i--)printf("%c",c[i]);
if(n==1) printf("\n");
else printf("\n\n");
n--;
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: