您的位置:首页 > 其它

【HDU-oj】-1061-Rightmost Digit(快速幂)

2016-07-22 15:16 281 查看


Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 47443    Accepted Submission(s): 17915


Problem Description

Given a positive integer N, you should output the most right digit of N^N.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

Output

For each test case, you should output the rightmost digit of N^N.

 

Sample Input

2
3
4

 

Sample Output

7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

 

这道题也可以找规律,每个末位数都有一个循环周期,n对其末位数循环周期取余即可判断输出几。

新学的快速幂理解记忆就好。

#include<cstdio>
int dis(int n,int m) //n的m次方
{
n%=10; //n可能太大,先对10求一次余
int ans=1;
while(m)
{
if(m&1) //m是奇数先取出一个n与ans相乘
ans=(ans*n)%10;
n=(n*n)%10;
m>>=1; //最后m一定为1,返回与ans相乘
}
return ans;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,ans;
scanf("%d",&n);
ans=dis(n,n);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: