您的位置:首页 > 其它

[暴力搜索]poj 1083 Moving Tables

2016-07-22 14:27 344 查看
Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.
Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 

Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 

line, the remaining test cases are listed in the same manner as above.
Output

The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50

Sample Output
10
20
30


思路:

①数据小,直接遍历,类似桶排即可

②线段树,树状树组(数据太小没必要用)

代码1(暴力):

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string.h>
#include <map>
#include <vector>
using namespace std;

typedef map<int, int> mii;
typedef vector<int> vi;
typedef pair<int, int> pii;

const int N = 210;
int main()
{
int a
;
int Max;
int t, n;
int from, to;
scanf("%d", &t);
while(t-- > 0)
{
scanf("%d", &n);
memset(a, 0, sizeof(a));
while(n-- > 0)
{
scanf("%d%d", &from, &to);
if(from > to)
{
int t = from;
from = to;
to = t;
}
from = (from - 1) / 2;
to = (to - 1) / 2;
for(int i = from; i <= to; i++)
a[i]++;
}
Max = 0;
for(int i = 1; i < N; i++)
Max = max(Max, a[i]);
printf("%d\n", Max*10);
}
return 0;
}


用到一个小技巧,

from = (from - 1) / 2;

to = (to - 1) / 2;

这样使奇偶对应起来,如

1 3 5 ……

2 4 6 ……

不需要在意就数公用一块走廊的问题了
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: