您的位置:首页 > 大数据 > 人工智能

2016 Multi-University Training Contest 2 Acperience

2016-07-22 11:47 501 查看


Acperience

http://acm.hdu.edu.cn/showproblem.php?pid=5734

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 513 Accepted Submission(s): 275



Problem Description

Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art
results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus),
augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems
need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,...,wn).
Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi∈{+1,−1}) and
a scaling factor α≥0 in
such a manner that ∥W−αB∥2 is
minimum.

Note that ∥⋅∥ denotes
the Euclidean norm (i.e. ∥X∥=x21+⋯+x2n−−−−−−−−−−−√,
where X=(x1,x2,...,xn)).

Input

There are multiple test cases. The first line of input contains an integer T,
indicating the number of test cases. For each test case:

The first line contains an integers n (1≤n≤100000) --
the length of the vector. The next line contains n integers: w1,w2,...,wn (−10000≤wi≤10000).

Output

For each test case, output the minimum value of ∥W−αB∥2 as
an irreducible fraction "p/q"
where p, q are
integers, q>0.

Sample Input

3
4
1 2 3 4
4
2 2 2 2
5
5 6 2 3 4


Sample Output

5/1
0/1
10/1


算是我的第一道数论题不难,然而并没有自己做出来

题意很简单给定w(−10000≤wi≤10000)
b 为正负1 自己找a使得

使得x^2最小

因为b为正负1 所以w全取绝对值 b全为正1 w-ab最小

把x^2拆开之后得到

(w1^2+w2^2+...+wn^2)
- 2*a*(w1+w2..wn)+n*a^2

当a
= -a/b (韦达)时a最小 即wi的平均数

结果要用分数就gcd通分记得gcd也longlong

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<stdlib.h>
#include<math.h>

using namespace std;

long long gcd(long long  a,long long  b)
{
if(a < b)
{
long long  t = a;
a = b;
b = t;
}
return !b ? a : gcd(b,a%b);
}

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
long long w;
long long sum = 0;
long long sum2 = 0;
long long n;
scanf("%I64d",&n);
for(int i = 0;i < n;i++)
{
scanf("%I64d",&w);
if(w<0)
w = 0-w;
sum += w;
sum2 += w*w;
}
long long num1 = n*sum2 - sum*sum;
long long GCD = gcd(num1,n);
printf("%I64d/%I64d\n",num1/GCD,n/GCD);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: