您的位置:首页 > 大数据 > 人工智能

hdu 5734 (2016 Multi-University Training Contest 2)

2016-07-22 11:23 447 查看

Acperience

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 493 Accepted Submission(s): 264



[align=left]Problem Description[/align]
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN),
have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus),
augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems
need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,...,wn).
Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi∈{+1,−1}) and
a scaling factor α≥0 in
such a manner that ∥W−αB∥2 is
minimum.

Note that ∥⋅∥ denotes
the Euclidean norm (i.e. ∥X∥=x21+⋯+x2n−−−−−−−−−−−√,
where X=(x1,x2,...,xn)).

[align=left]Input[/align]
There are multiple test cases. The first line of input contains an integer T,
indicating the number of test cases. For each test case:

The first line contains an integers n (1≤n≤100000) --
the length of the vector. The next line contains n integers: w1,w2,...,wn (−10000≤wi≤10000).

[align=left]Output[/align]
For each test case, output the minimum value of ∥W−αB∥2 as
an irreducible fraction "p/q"
where p, q are
integers, q>0.

[align=left]Sample Input[/align]

3
4
1 2 3 4
4
2 2 2 2
5
5 6 2 3 4


[align=left]Sample Output[/align]

5/1
0/1
10/1


[align=left]Author[/align]
zimpha

[align=left]Source[/align]
2016 Multi-University
Training Contest 2

题意:给定一个向量W =(w1,w2...wn),一个向量B = {+1,-1},一个实数a > 0;求最小的 || W - aB ||。

分析:起初咋一看这题,恩...好大的数,是大数吧,再一看,恩...小数化分数,无限小数咋办!@#¥*&¥#.....最后,化简公式....AC.....扯犊子一样;

首先,因为 B 可为+ - 1,所以W - aB 要最小就相当于 | W | - a(w1,w2...wn的平均数),然后完全平方展开,得 wi^2 - 2*wi*a + a^2;

化简,(n*sum1 - sum2^2)/n ;sum1是W的平方和,sum2是W的和。呵呵....

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 1e9;
const int MOD = 1e9+7;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define lson (i<<1)
#define rson ((i<<1)|1)
#define N 100010

int n;
ll x,sum1,sum2;

double ww;

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
sum1 = sum2 = 0;
for(int i=0; i<n; i++)
{
scanf("%lld",&x);
x = abs(x);
sum1 += x*x;
sum2 += x;
}
ll p,q;
q = n*sum1-sum2*sum2;
p = n;
printf("%lld/%lld\n",q/__gcd(q,p),p/__gcd(q,p));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: