您的位置:首页 > 其它

HDU 1046 & POJ 1450 Gridland【有趣的数学题】

2016-07-22 11:00 399 查看


Gridland

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5697 Accepted Submission(s): 2607



Problem Description

For years, computer scientists have been trying to find efficient solutions to different computing problems. For some of them efficient algorithms are already available, these are the “easy” problems like sorting, evaluating a polynomial or finding the shortest
path in a graph. For the “hard” ones only exponential-time algorithms are known. The traveling-salesman problem belongs to this latter group. Given a set of N towns and roads between these towns, the problem is to compute the shortest path allowing a salesman
to visit each of the towns once and only once and return to the starting point.

The president of Gridland has hired you to design a program that calculates the length of the shortest traveling-salesman tour for the towns in the country. In Gridland, there is one town at each of the points of a rectangular grid. Roads run from every town
in the directions North, Northwest, West, Southwest, South, Southeast, East, and Northeast, provided that there is a neighbouring town in that direction. The distance between neighbouring towns in directions North–South or East–West is 1 unit. The length of
the roads is measured by the Euclidean distance. For example, Figure 7 shows 2 × 3-Gridland, i.e., a rectangular grid of dimensions 2 by 3. In 2 × 3-Gridland, the shortest tour has length 6.



Input

The first line contains the number of scenarios.

For each scenario, the grid dimensions m and n will be given as two integer numbers in a single line, separated by a single blank, satisfying 1 < m < 50 and 1 < n < 50.

Output

The output for each scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. In the next line, print the length of the shortest traveling-salesman tour rounded to two decimal digits. The output for every scenario
ends with a blank line.

Sample Input

2
2 2
2 3


Sample Output

Scenario #1:
4.00

Scenario #2:
6.00


Source

Northwestern Europe 2001

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1046


题意:

输入一个n*m的点阵,间距为1,问你遍历完所有点阵并回到起点的最短路径是多少。

画图就能找到规律。



规律:当n,m不全为奇数的时候,最短路径就是n*m;

当n,m全为奇数的时候,必然要走一条斜线,就多走了0.41(即根号2),最短路径即为:n*m+0.41.


AC代码:

#include <cstdio>
int main()
{
int total;
int m,n;
int i;
scanf("%d",&total);
for(i=1; i <= total ; i++)
{
scanf("%d%d",&m,&n);
printf("Scenario #%d:\n",i);
if((m*n)%2 == 0)
printf("%d.00\n",m*n);
else
printf("%d.41\n",m*n);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: