您的位置:首页 > 其它

HDU 5734 Acperience (观察)

2016-07-22 10:32 246 查看
题目链接:HDU 5734

题面:

Acperience

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 475    Accepted Submission(s): 251


[align=left]Problem Description[/align]
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN),
have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus),
augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems
need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector
W=(w1,w2,...,wn).
Professor Zhang would like to find a binary vector
B=(b1,b2,...,bn)(bi∈{+1,−1})
and a scaling factor α≥0
in such a manner that ∥W−αB∥2
is minimum.

Note that ∥⋅∥
denotes the Euclidean norm (i.e. ∥X∥=x21+⋯+x2n−−−−−−−−−−−√,
where X=(x1,x2,...,xn)).
 

[align=left]Input[/align]
There are multiple test cases. The first line of input contains an integerT,
indicating the number of test cases. For each test case:

The first line contains an integers n(1≤n≤100000)
-- the length of the vector. The next line contains
n
integers: w1,w2,...,wn(−10000≤wi≤10000).
 

[align=left]Output[/align]
For each test case, output the minimum value of
∥W−αB∥2
as an irreducible fraction "p/q"
where p,q
are integers, q>0.
 

[align=left]Sample Input[/align]

3
4
1 2 3 4
4
2 2 2 2
5
5 6 2 3 4

 

[align=left]Sample Output[/align]

5/1
0/1
10/1

 

[align=left]Author[/align]
zimpha
 

[align=left]Source[/align]
2016 Multi-University Training Contest 2

题意:

    已知w序列,要求你确定阿尔法和B序列的{-1,1}的取值,使得
∥W−αB∥2的值最小。

解题:

    先将最终表达式展开,假定B序列的取值已定,根据二次函数的特性,取阿尔法的值为-b/2a。代入式子,发现(sigma(bi*wi))^2的值越大,整个式子的值越小,故当wi为负时,bi取负,反之取正。

代码:

#include <iostream>
#include <cstdio>
#define LL long long
using namespace std;
int w[100005];
int abs(int x)
{
if(x<0)return -x;
return x;
}
LL gcd(LL a,LL b)
{
if(a==0)return b;
return gcd(b%a,a);
}
int main()
{
int t,n;
LL fenzi,fenmu,wsum,tgcd;
scanf("%d",&t);
while(t--)
{
wsum=0;
scanf("%d",&n);
fenmu=n;
for(int i=1;i<=n;i++)
{
scanf("%d",&w[i]);
wsum+=w[i]*w[i];
}
fenzi=1LL*n*wsum;
wsum=0;
for(int i=1;i<=n;i++)
{
wsum+=abs(w[i]);
}
wsum*=wsum;
fenzi-=wsum;
tgcd=gcd(fenzi,fenmu);
printf("%lld/%lld\n",fenzi/tgcd,fenmu/tgcd);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 入门