您的位置:首页 > 其它

poj3122Pie(2)

2016-07-22 09:32 351 查看
[align=center]Pie[/align]

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14853 Accepted: 5094 Special Judge
就是公平地分披萨pie

我生日,买了n个pie,找来f个朋友,那么总人数共f+1人

每个pie都是高为1的圆柱体,输入这n个pie的每一个尺寸(半径),如果要公平地把pie分给每一个人(就是所有人得到的pie尺寸一致,但是形状可以不同),而且每个人得到的那份pie必须是从同一个pie上得到的

后面那句很重要,

就是说如果有3个pie, 尺寸分别为1,2,3,

如果要给每人尺寸为2的pie,那么最多分给2个人,而不是3个人

因为第一个pie尺寸为1,小于2,扔掉

第二个pie尺寸为2,等于2,刚好分给一个人

第三个pie尺寸为3,切出尺寸为2的一份,分给一个人,剩下的尺寸为1的就扔掉

Description


My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various
sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is
better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output
25.1327
3.1416
50.2655

Source

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#define eps 1e-6
using namespace std;
int t,n,m;
const double pi=acos(-1.0);
const int N=1e5+10;
double V
;
bool ok(double x)
{
int cnt=0;
for(int i=0;i<n;i++)
{
cnt+=(int)(V[i]/x);
}
return cnt>=m;
}
int main()
{

scanf("%d",&t);
double x;
while(t--)
{
scanf("%d%d",&n,&m);
m++;
double mm=0;
for(int i=0;i<n;i++)
{
scanf("%lf",&x);
V[i]=x*x*pi;
mm=max(mm,V[i]);
}
double l=0,r=mm,mid;
double ans=0;
while(r-l>eps)
{
mid=(l+r)/2;
if(ok(mid))
ans=mid,l=mid;
else
r=mid;
}
printf("%.4f\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: