您的位置:首页 > 其它

NYOJ-18-The Triangle(动态规划)

2016-07-22 08:45 429 查看
The Triangle

时间限制:1000 ms | 内存限制:65535 KB

难度:4

描述

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

输出

Your program is to write to standard output. The highest sum is written as an integer.

样例输入

5

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

样例输出

30

题意:给出这样的数字三角形,起点是顶点,终点是底边任意一点,每一步可以向下,或者向下后再向左,求出经过数字最大和

思路:状态转移方程DP[i][j]=max(DP[i][j],DP[i-1][j]+map[i][j]),i-1>=1;

DP[i][j]=max(DP[i][j],DP[i-1][j-1]+map[i][j]),i-1>=1&&j-1>=1

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<iomanip>
using namespace std;
const int maxn=105;
int map[maxn][maxn];
int DP[maxn][maxn];
int main()
{
int N;
while(~scanf("%d",&N))
{
for(int i=1; i<=N; i++)
for(int j=1; j<=i; j++)
scanf("%d",&map[i][j]);
memset(DP,0,sizeof(DP));
DP[1][1]=map[1][1];
for(int i=2; i<=N; i++)
{
for(int j=1; j<=i; j++)
{
if(i-1>=1&&j-1>=1)
DP[i][j]=max(DP[i][j],DP[i-1][j-1]+map[i][j]);
if(i-1>=1)
DP[i][j]=max(DP[i][j],DP[i-1][j]+map[i][j]);
}
}
int max_num=0;
for(int i=1; i<=N; i++)
max_num=max(max_num,DP
[i]);
printf("%d\n",max_num);
}
return 0;
}


做点小优化

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<iomanip>
using namespace std;
const int maxn=105;
int map[maxn][maxn];
int DP[maxn][maxn];
int main()
{
int N;
while(~scanf("%d",&N))
{
for(int i=1; i<=N; i++)
{
for(int j=1; j<=i; j++)
{
scanf("%d",&map[i][j]);
DP[i][j]=max(DP[i-1][j],DP[i-1][j-1])+map[i][j];
}
}
int max_num=0;
for(int i=1; i<=N; i++)
max_num=max(max_num,DP
[i]);
printf("%d\n",max_num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: