您的位置:首页 > 其它

文章标题HDU2899:Strange fuction?(二分+精度)

2016-07-22 00:24 393 查看

Strange fuction

Description

Now, here is a fuction:

F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)

Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2

100

200

Sample Output

-74.4291

-178.8534

题意:求解f(x)在0到100之间的最小值

分析:有题意可知可对f(x)求导,判断导函数与y值的大小关系进行二分。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<math.h>
#include<algorithm>
using namespace std;
double F(double x,double y){
return (6*x*x*x*x*x*x+8*x*x*x*x*x+7*x*x+5*x-y)*x;
}
long double F1(double x){
return 42*x*x*x*x*x*x+x*x*x*x*x*48+21*x*x+10*x;
}
int main ()
{
double y;
int total;
scanf ("%d",&total);
while(total--){
scanf ("%lf",&y);
double lo=0.0,hi=100.0;
double mi=50.0;
int k=200;
while (k--){

if (F1(mi)<y)lo=mi;
else if (F1(mi)>y)hi=mi;
mi=(hi+lo)/2.0;
}
printf ("%.4lf\n",F(mi,y));
}

return 0;
}


注:所示代码通过控制循环次数的方法得到精度;除此之外,自身也可以定义一个精度,但得防止精度过高导致死循环。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  二分-+-精度