您的位置:首页 > 其它

hdoj 1398 Square Coins <递归+状态记录优化----母函数????>

2016-07-21 23:51 337 查看


Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11095    Accepted Submission(s): 7596


Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are
available in Silverland. 

There are four combinations of coins to pay ten credits: 

ten 1-credit coins,

one 4-credit coin and six 1-credit coins,

two 4-credit coins and two 1-credit coins, and

one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

 

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

 

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 

 

Sample Input

2
10
30
0

 

Sample Output

1
4
27

 

Source

Asia 1999, Kyoto (Japan)

钱的大小可sqrt()压缩----便于运用---

递归+状态记录优化  代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long
int bei[20];
LL shu[330],F[20][320];
LL f(int da,int pp)
{
if (pp==0)
return 1;
if (da==0)
return 0;
LL lp=0;
for (int i=da;i>0;i--)
{
int ge=pp/bei[i];
for (int j=1;j<=ge;j++)
{
int qian=i-1;
while (bei[qian]>pp-j*bei[i])
qian--;
if (!F[qian][pp-j*bei[i]])
F[qian][pp-j*bei[i]]=f(qian,pp-j*bei[i]);
lp+=F[qian][pp-j*bei[i]];
}
}
return lp;
}
int main()
{
int n;
for (int i=0;i<=18;i++)
{
bei[i]=i*i;
}
memset(shu,0,sizeof(shu));
memset(F,0,sizeof(F));
while (scanf("%d",&n),n)
{
if (shu
)
printf("%lld\n",shu
);
else
{
for (int i=17;i>0;i--)
if (n>=bei[i])
{
shu
=f(i,n);
break;
}
printf("%lld\n",shu
);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: