您的位置:首页 > 其它

大数相加NYOJ103

2016-07-21 20:34 357 查看
NYOJ103

A+B Problem II

时间限制:3000 ms | 内存限制:65535 KB

难度:3

描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.


输入

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

输出

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation.

样例输入

2
1 2
112233445566778899 998877665544332211


样例输出

Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


#include <stdio.h>
#include <string.h>
char a[1005];
char b[1005];
int c[1005];
int main()
{
int T,t=0;
scanf("%d",&T);
getchar();
while(T--)
{
memset(c,0,sizeof(c));
scanf("%s%s",a,b);
int la=strlen(a);
int lb=strlen(b);
int i,j,s,k=0,v=0;
for(i=la-1,j=lb-1;;i--,j--)
{
if(i<0&&j<0)
break;
if(i<0)
s=(b[j]-'0')+v;
else if(j<0)
s=(a[i]-'0')+v;
else
s=(a[i]-'0')+(b[j]-'0')+v;
c[k]=s%10;
v=s/10;
if((i==0&&j<=0||i<=0&&j==0)&&v!=0)
c[++k]=v;
k++;
}
printf("Case %d:\n",++t);
printf("%s + %s = ",a,b);
for(i=k-1;i>=0;i--)
printf("%d",c[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: