您的位置:首页 > 其它

Hdu oj 1013 Digital Roots(九余数定理)

2016-07-21 20:15 323 查看

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 69541    Accepted Submission(s): 21746


[align=left]Problem Description[/align]
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are
summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

 

[align=left]Input[/align]
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

 

[align=left]Output[/align]
For each integer in the input, output its digital root on a separate line of the output.

 

[align=left]Sample Input[/align]

24
39
0

 

[align=left]Sample Output[/align]

6
3

因为不会有正数各位之和为0,所以只会有1-9这9个根。
假设,数d的根为d%9!!!!!!!!(不取0,整除时取9)
首先,1-9这9个数成立
假定,d的根为d%9,则d+1的根为d的根+1,即d%9+1=(d+1)%9.
得证。
不过这道题要记得特判9,因为9对9取余是0。
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;

const int maxn = 1005;
char x[maxn];

int main()
{
while(cin>>x && x[0] != '0')
{
int len = strlen(x);
int sum = 0;
for(int i=0;i<len;i++)
{
sum += x[i] - '0';
}
while(sum > 9)
{
sum %= 9;
}
if(sum == 0)
cout<<9<<endl;
else
cout<<sum<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息