您的位置:首页 > 大数据 > 人工智能

2016 Multi-University Training Contest 2 1001 hdu 5734 暴力

2016-07-21 17:24 525 查看
链接:戳这里

Acperience

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Problem Description

Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art
results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus),
augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems
need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,...,wn). Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi∈{+1,−1}) and a scaling factor α≥0 in such a manner that ∥W−αB∥2 is minimum.

Note that ∥⋅∥ denotes the Euclidean norm (i.e. ∥X∥=x21+⋯+x2n−−−−−−−−−−−√, where X=(x1,x2,...,xn)).

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integers n (1≤n≤100000) -- the length of the vector. The next line contains n integers: w1,w2,...,wn (−10000≤wi≤10000).

 

Output

For each test case, output the minimum value of ∥W−αB∥2 as an irreducible fraction "p/q" where p, q are integers, q>0.

 

Sample Input

3

4

1 2 3 4

4

2 2 2 2

5

5 6 2 3 4

 

Sample Output

5/1

0/1

10/1

 

思路:

很容易得出这个a是所有wi的平均值。但是会爆long long ,注意这里

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include <ctime>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<iomanip>
#include<cmath>
#define mst(ss,b) memset((ss),(b),sizeof(ss))
#define maxn 0x3f3f3f3f
#define MAX 1000100
///#pragma comment(linker, "/STACK:102400000,102400000")
typedef long long ll;
typedef unsigned long long ull;
#define INF (1ll<<60)-1
using namespace std;
ll w[100100];
int n;
ll gcd(ll a,ll b){
return b==0?a:gcd(b,a%b);
}
int main(){
int T;
scanf("%d",&T);
while(T--){
ll sum=0;
scanf("%d",&n);
for(int i=1;i<=n;i++) {
scanf("%I64d",&w[i]);
w[i]=abs(w[i]);
sum+=w[i];
}
ll ans=sum*sum;
for(int i=1;i<=n;i++){
ans+=1LL*w[i]*w[i]*n-2LL*sum*w[i];
}
if(ans==0) printf("0/1\n");
else {
ll a=1LL*n;
ll tmp=gcd(a,ans);
a/=tmp;
ans/=tmp;
printf("%I64d/%I64d\n",ans,a);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: