您的位置:首页 > 大数据 > 人工智能

2016 Multi-University Training Contest 2 Acperience

2016-07-21 16:06 344 查看


Acperience

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 730    Accepted Submission(s): 188


Problem Description

Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art
results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus),
augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems
need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,...,wn).
Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi∈{+1,−1})and
a scaling factor α≥0 in
such a manner that ∥W−αB∥
       2 is minimum.

Note that ∥⋅∥ denotes
the Euclidean norm (i.e. ∥X∥=x21+⋯+x2n−−−−−−−−−−√,
where X=(x1,x2,...,xn)).

 

Input

There are multiple test cases. The first line of input contains an integer T,
indicating the number of test cases. For each test case:

The first line contains an integers n (1≤n≤100000) --
the length of the vector. The next line contains n integers: w1,w2,...,wn (−10000≤wi≤10000).

 

Output

For each test case, output the minimum value of ∥W−αB∥2 as
an irreducible fraction "p/q"
where p, q are
integers, q>0.

 

Sample Input

3
4
1 2 3 4
4
2 2 2 2
5
5 6 2 3 4

 

Sample Output

5/1
0/1
10/1

 
思路:

本题要求∥W−αB∥^2的最小值,而根据题目中所说的对//。//定义,也就是求(W1-α*B)^2+(W2-α*B)^2+(W3-α*B)^2

+……+(Wn-α*B)^2的最小值,对于α>=0且是未知的,可以通过变换B让每一项最小,当Wi为正的时候,取B=1,

(Wi-α)^2,反之,<
c772
/span>取-1,(Wi+α)^2=(-Wi-α)^2;可归结为(|Wi|-α)^2。这是一个求方差公式,当α取平均

值时,可使值最小。

AC代码:

对于(|Wi|-α)^2展开得(Wi)^2-2*|Wi|*α+α^2;

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
#define INF 999999999

__int64 gcd(__int64 a,__int64 b)//求最大公约数
{
__int64 k,temp;
if(a<b)
{
temp=a;a=b;b=temp;
}
while(b!=0)
{
k=a%b;
a=b;b=k;
}
return a;
}

int main()
{
__int64 t,i,j,n,x[100101];
scanf("%I64d",&t);
while(t--)
{
scanf("%I64d",&n);
__int64 sum=0,suma=0;
for(i=0;i<n;i++)
{
scanf("%I64d",&x[i]);
sum+=abs(x[i]);//对所有值的绝对值求和
suma+=abs(x[i]*x[i]);
}
__int64 sumcz=sum/gcd(sum,n)*sum;
__int64 sumcm=n/gcd(sum,n);
sumcz=suma*sumcm-sumcz;

printf("%I64d/%I64d\n",(sumcz/gcd(sumcz,sumcm)),sumcm/gcd(sumcz,sumcm));

}
return 0;
}


错误代码:(由于中间会出现数值太大,爆内存情况)

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
#define INF 999999999

__int64 gcd(__int64 a,__int64 b)
{
__int64 k,temp;
if(a<b)
{
temp=a;a=b;b=temp;
}
while(b!=0)
{
k=a%b;
a=b;b=k;
}
return a;
}

int main()
{
__int64 t,i,j,n,x[100101];
scanf("%I64d",&t);
while(t--)
{
scanf("%I64d",&n);
__int64 sum=0;
for(i=0;i<n;i++)
{
scanf("%I64d",&x[i]);
sum+=abs(x[i]);
}
__int64 bsum=0;
for(i=0;i<n;i++)
{
bsum=bsum+(abs(n*x[i])-sum)*(abs(n*x[i])-sum);
}

printf("%I64d/%I64d\n",(bsum/gcd(bsum,n*n)),(n*n)/gcd(bsum,n*n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: