您的位置:首页 > 理论基础 > 数据结构算法

HDU 5233 Gunner II 数据结构map+vector

2016-07-21 11:55 330 查看
B - Gunner II
Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d
& %I64u
SubmitStatus

Description

Long long ago, there was a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are n birds and n trees. The i-th bird stands on the top of the i-th tree. The trees stand in straight line
from left to the right. Every tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the nearest bird which stands in the tree with height H will falls.

Jack will shot many times, he wants to know which bird will fall during each shot.

 

Input

There are multiple test cases (about 5), every case gives n, m in the first line, n indicates there are n trees and n birds, m means Jack will shot m times.

In the second line, there are n numbers h[1],h[2],h[3],…,h
which describes the height of the trees.

In the third line, there are m numbers q[1],q[2],q[3],…,q[m] which describes the height of the Jack’s shots.

Please process to the end of file.

[Technical Specification]

All input items are integers.

1<=n,m<=100000(10^5)

1<=h[i],q[i]<=1000000000(10^9)

 

Output

For each q[i], output an integer in a single line indicates the id of bird Jack shots down. If Jack can’t shot any bird, just output -1.

The id starts from 1.

 

Sample Input

5 5
1 2 3 4 1
1 3 1 4 2

 

Sample Output

1
3
5
4
2

Hint
Huge input, fast IO is recommended.

解题思路:

做这题的时候错了很多次,这题主要就是:

1,鸟的高度太多了,需要map进行映射,然后存储每一个鸟的位置。
2,同一个高度可能有很多的鸟,打下来的是下标最小的,所以需要一个链式的结构去存,不能用二维数组

因为二维数组开不了那么大,所以就用vector了。

3,对于每一个vector打掉一只鸟不能用erase删除元素,那么就不删除元素,再定义一个数组,记录每一个vector的最左边的鸟的位置即可。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<map>
#include<vector>
using namespace std;
const int maxn = 100005 ;
int h[maxn] ;
int q[maxn] ;
int x[maxn] ;
vector<int> s[maxn] ;
map<int,int>qq ;
int main(){
int n,m;
while(~scanf("%d%d",&n,&m)){
qq.clear();
int c = 1 ;
for(int i=0;i<n;i++){
scanf("%d",&h[i]);
if(!qq.count(h[i])){
qq[h[i]] = c++;
s[qq[h[i]]].clear();
x[qq[h[i]]] = 0 ;
}
s[qq[h[i]]].push_back(i+1);
}
for(int i=0;i<m;i++){
scanf("%d",&q[i]);
//printf("as = %d %d\n",qq[q[i]],qq.count(q[i]));
if(x[qq[q[i]]]>=s[qq[q[i]]].size()||!qq.count(q[i]))printf("-1\n");
else{
printf("%d\n",s[qq[q[i]]][x[qq[q[i]]]]);
x[qq[q[i]]]++ ;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: