您的位置:首页 > 其它

杭电 ACM 几道有关string的题目

2016-07-21 08:52 309 查看


HDU 1200

To and Fro

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6305    Accepted Submission(s): 4326

[align=left]Problem Description[/align]
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as
to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y

h p k n n

e l e a i

r a h s g

e c o n h

s e m o t

n l e w x

Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

 

[align=left]Input[/align]
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string
of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

 

[align=left]Output[/align]
Each input set should generate one line of output, giving the original plaintext message, with no spaces.

 

[align=left]Sample Input[/align]

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

 

[align=left]Sample Output[/align]

theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

解题思路:从string中取n个字符为一行,当时偶数行时按照顺序排列,为奇数时按逆序排列。
注意:如果你是我这种做法,要注意k++的位置,它要写在赋值给字符数组的那个for循环里面。

我的代码:
<span style="color:#333333;">#include<iostream>
#include<string>
using namespace std;
int main()
{
string str;
int i,j,n,k,size;
char c[100][100];
while(cin>>n && n != 0)
{
i = 0;
getchar();
getline(cin,str);
size = str.size();

for(k = 0;k < size;)
{
if(i % 2 == 0)
{
for(j = 0;j < n;j++,k++)
{
c[i][j] = str[k];
}
}
else
{
for(j = n-1;j >= 0;j--,k++)
{
c[i][j] = str[k];
}
}
i++;
}

for(j = 0;j < n;j++)
{
for(i = 0;i < size/n;i++)
{
cout<<c[i][j];
}
}
cout<<endl;
}
return 0;
}</span>

HDU  1062

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 26350    Accepted Submission(s): 10247

[align=left]Problem Description[/align]
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

 

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single line with several words. There will be at most 1000 characters in a line.

 

[align=left]Output[/align]
For each test case, you should output the text which is processed.

 

[align=left]Sample Input[/align]

3
olleh !dlrow
m'I morf .udh
I ekil .mca

 

[align=left]Sample Output[/align]

hello world!
I'm from hdu.
I like acm.

 
我的代码:

#include <iostream>
#include <algorithm>
#include <string>
using namespace std;
int main()
{
int n,i;
string str;
cin>>n;
getchar();

while(n--)
{
i = 0;
getline(cin,str);
while(str.find(" ",i) != str.npos)
{
reverse (str.begin() + i, str.begin() + str.find (" ",i));
i = str.find (" ",i) + 1;
}
reverse(str.begin() + str.find_last_of(" ",i) + 1, str.end());
cout<<str<<endl;
}
return 0;
}

HDU  2017

字符串统计

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 68069    Accepted Submission(s): 37333

[align=left]Problem Description[/align]
对于给定的一个字符串,统计其中数字字符出现的次数。
 

[align=left]Input[/align]
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
 

[align=left]Output[/align]
对于每个测试实例,输出该串中数值的个数,每个输出占一行。
 

[align=left]Sample Input[/align]

2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

 

[align=left]Sample Output[/align]

6
9

我的代码:
#include<iostream>
#include<string>
#include<stdio.h>
using namespace std;
int main()
{
int n,k;
string str;
scanf("%d",&n);
getchar();
while(n--)
{
getline(cin,str);
k = 0;
for (int i = 0; i < str.length(); i++)
{
if(isdigit(str[i])) k++;
}
printf("%d\n",k);
}
return 0;
}


这两个题主要是熟悉string的一些相关用法
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: