您的位置:首页 > 其它

抓牛(poj4001)BFS

2016-07-20 17:45 225 查看

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

解题思路:

建立队列,通过bfs找寻最优解


code:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
struct node
{
int x,c;
}pos[200000];//该点的坐标和走过的步数
int n,k;
queue<node>q;//队列
bool vis[200000];//判断是否走过该点
int bfs()
{
int p,cnt;
while(!q.empty())
{
p=q.front().x;
cnt=q.front().c;
q.pop();
if(p==k)return cnt;
if(!vis[p-1]&&p>0)
{
vis[p-1]=1;
pos[p-1].c=cnt+1;
pos[p-1].x=p-1;
q.push(pos[p-1]);
}
if(p<k)
{
if(!vis[p+1])
{
vis[p+1]=1;
pos[p+1].c=cnt+1;
pos[p+1].x=p+1;
q.push(pos[p+1]);
}
if(!vis[2*p])
{
vis[2*p]=1;
pos[2*p].c=cnt+1;
pos[2*p].x=2*p;
q.push(pos[2*p]);
}
}
}
}
int main()
{
cin>>n>>k;
memset(vis,0,sizeof(vis));
memset(pos,0,sizeof(pos));
vis
=1;
pos
.x=n;
pos
.c=0;
q.push(pos
);
cout<<bfs()<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: