您的位置:首页 > 其它

the Sum of Cube hd 5053

2016-07-20 16:01 411 查看
Description

A range is given, the begin and the end are both integers. You should sum the cube of all the integers in the range.

Input

The first line of the input is T(1 <= T <= 1000), which stands for the number of test cases you need to solve.

Each case of input is a pair of integer A,B(0 < A <= B <= 10000),representing the range[A,B].

Output

For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then output the answer – sum the cube of all the integers in the range.

Sample Input

2

1 3

2 5

Sample Output

Case #1: 36
Case #2: 224

#include<stdio.h>
int main()
{
int i,a,b,n;
int cas=0;
__int64 sum;
scanf("%d",&n);
while(n--)
{
cas++;
sum=0;
scanf("%d%d",&a,&b);
for(i=a;i<=b;i++)
{
sum+=(__int64)i*i*i;
}
printf("Case #%d: %I64d\n",cas,sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: