您的位置:首页 > 其它

Hdu1240 Asteroids!(三维BFS)

2016-07-20 14:56 375 查看

Asteroids!

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4775 Accepted Submission(s): 3070

[/b]

[align=left]Problem Description[/align]
You're in space.

You want to get home.

There are asteroids.

You don't want to hit them.

[align=left]Input[/align]
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.

[align=left]Output[/align]
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to
the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

[align=left]Sample Input[/align]

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END


[align=left]Sample Output[/align]

1 0
3 4
NO ROUTE


思路:题目主要是长,其实并不难,题中第一行输入数n,接下来输入n*n*n的三维图,'O'表示能走,'X'不能走,倒数2、3行表示起点和终点的x、y、z坐标,能抵达的话输出n和最小步数,不能抵达则输出"NO ROUTE",用三维的BFS即可。

#include<iostream>
#include<queue>
#include<cstring>
struct node
{
int x,y,z,step;
};
node st,ne,q,ed;
int to[6][3]={1,0,0 , 0,1,0 , 0,0,1 ,-1,0,0 , 0,-1,0 ,0,0,-1};
char map[30][30][30];
bool vis[30][30][30];
bool flag;
int n;
void bfs(void);
using namespace std;
int main(void)
{
char chs[100];
while(cin>>chs)
{
cin>>n;
for(int k=0;k<n;k++)
{
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
cin>>map[k][i][j];
}
}
}

cin>>st.x;
cin>>st.y;
cin>>st.z;

cin>>ed.x;
cin>>ed.y;
cin>>ed.z;

st.step=0;
ed.step=0;

cin>>chs;

memset(vis,0,sizeof(vis));
flag=false;

bfs();

if(!flag)
{
cout<<"NO ROUTE"<<endl;
}
}
return 0;
}
void bfs(void)
{
queue<node> que;
que.push(st);

while(!que.empty())
{
q=que.front();
que.pop();
if(q.x==ed.x && q.y==ed.y && q.z==ed.z)
{
cout<<n<<" "<<q.step<<endl;
flag=true;
return ;
}

for(int i=0;i<6;i++)
{
ne.x=q.x+to[i][0];
ne.y=q.y+to[i][1];
ne.z=q.z+to[i][2];

if(ne.x>=0 &&ne.x<n &&ne.y>=0 &&ne.y <n &&ne.z>=0 &&ne.z<n &&!vis[ne.z][ne.y][ne.x] && map[ne.z][ne.y][ne.x]=='O')
{
vis[ne.z][ne.y][ne.x]=true;
ne.step=q.step+1;
que.push(ne);
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: