您的位置:首页 > 其它

博弈论

2016-07-20 14:54 260 查看

Chess

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 678    Accepted Submission(s): 277
[/b]

[align=left]Problem Description[/align]
Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess,
move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during
his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.
 

[align=left]Input[/align]
Multiple test cases.

The first line contains an integer T(T≤100),
indicates the number of test cases.

For each test case, the first line contains a single integer
n(n≤1000),
the number of lines of chessboard.

Then n
lines, the first integer of ith line is m(m≤20),
indicates the number of chesses on the ith line of the chessboard. Then m integers
pj(1≤pj≤20)
followed, the position of each chess.

 

[align=left]Output[/align]
For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.
 

[align=left]Sample Input[/align]

2
1
2 19 20
2
1 19
1 18

 

[align=left]Sample Output[/align]

NO
YES
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;

const int INF = 0x3f3f3f3f;

int sg[1<<21],s[21];
int n,m,k;

void getsg(int n)
{
memset(sg,0,sizeof(sg));
for(int i=1;i<=n;i++)
{
memset(s,0,sizeof(s));
for(int j=20;j>=0;j--)
{
if(i&(1<<j))
{
int tmp=i;
for(int k=j-1;k>=0;k--)
{
if(!(i&(1<<k)))
{
tmp^=((1<<j)^(1<<k));
s[sg[tmp]]=1;
break;
}
}
}
}
for(int v=0;v<=20;v++)
{
if(s[v]==0)
{
sg[i]=v;
break;
}
}
}
}

int main()
{
getsg(1<<20);
int t;
scanf("%d",&t);
while(t--)
{
int ans=0;
scanf("%d",&n);
while(n--)
{
scanf("%d",&m);
int sum=0;
while(m--)
{
scanf("%d",&k);
sum+=(1<<(20-k));
}
ans^=sg[sum];
}
printf("%s\n", ans ? "YES" : "NO");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: