您的位置:首页 > 其它

Function Run Fun

2016-07-20 14:48 162 查看
Description

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 



if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 

w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 

w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 

w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1


Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1


#include <iostream>

using namespace std;
long long w(int a,int b,int c);
int main()
{
int a,b,c;
while(cin>>a>>b>>c&&(a!=-1||b!=-1||c!=-1)){
cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<w(a,b,c)<<endl;
}
return 0;
}
long long w(int a,int b,int c){
if(a<=0||b<=0||c<=0) return 1;
long long dp[25][25][25];
int i,j,k;
for(i=0;i<=20;i++){
for(j=0;j<=20;j++)
for(k=0;k<=20;k++){
dp[i][j][k]=1;
}
}
for(i=1;i<=20;i++){
for(j=1;j<=20;j++){
for(k=1;k<=20;k++){
if(i<j&&j<k) dp[i][j][k]=dp[i][j][k-1]+dp[i][j-1][k-1]-dp[i][j-1][k];
else dp[i][j][k]=dp[i-1][j][k]+dp[i-1][j-1][k]+dp[i-1][j][k-1]-dp[i-1][j-1][k-1];
}
}
}
/* for(i=0;i<=20;i++){
for(j=0;j<=20;j++){
for(k=0;k<=20;k++){
cout<<dp[i][j][k]<<" ";
}
cout<<endl;
}
}*/
if(a>20||b>20||c>20) return dp[20][20][20];
return dp[a][b][c];
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: