您的位置:首页 > 其它

HDOJ 1222 Wolf and Rabbit

2016-07-20 11:08 483 查看

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7212 Accepted Submission(s): 3607



[align=left]Problem Description[/align]
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are
signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

[align=left]Input[/align]
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

[align=left]Output[/align]
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.

[align=left]Sample Input[/align]

2
1 2
2 2


[align=left]Sample Output[/align]

NO
YES


[align=left]Author[/align]
weigang Lee

[align=left]Source[/align]
杭州电子科技大学第三届程序设计大赛

应该算是数学题的范围。

只有n,m最大公约数是1的时候才能走到n=1这个洞。其余应该都是最大公约数是几过几个洞查看一下。

代码如下:

#include<stdio.h>
int GCD(int a,int b)
{
if(a%b==0)
return b;
else
return GCD(b,a%b);
}
int main()
{
int T;
int m,n;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&m,&n);
if(GCD(m,n)==1)
printf("NO\n");
else
printf("YES\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: