您的位置:首页 > 其它

poj1128 Frame Stacking (拓扑排序+构图+回溯输出路径)

2016-07-20 10:36 330 查看
Frame Stacking

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 5165Accepted: 1794
Description
Consider the following 5 picture frames placed on an 9 x 8 array.

........ ........ ........ ........ .CCC....

EEEEEE.. ........ ........ ..BBBB.. .C.C....

E....E.. DDDDDD.. ........ ..B..B.. .C.C....

E....E.. D....D.. ........ ..B..B.. .CCC....

E....E.. D....D.. ....AAAA ..B..B.. ........

E....E.. D....D.. ....A..A ..BBBB.. ........

E....E.. DDDDDD.. ....A..A ........ ........

E....E.. ........ ....AAAA ........ ........

EEEEEE.. ........ ........ ........ ........

1        2        3        4        5


Now place them on top of one another starting with 1 at the bottom and ending up with 5 on top. If any part of a frame covers another it hides that part of the frame below.

Viewing the stack of 5 frames we see the following.

.CCC....

ECBCBB..

DCBCDB..

DCCC.B..

D.B.ABAA

D.BBBB.A

DDDDAD.A

E...AAAA

EEEEEE..


In what order are the frames stacked from bottom to top? The answer is EDABC.

Your problem is to determine the order in which the frames are stacked from bottom to top given a picture of the stacked frames. Here are the rules:

1. The width of the frame is always exactly 1 character and the sides are never shorter than 3 characters.

2. It is possible to see at least one part of each of the four sides of a frame. A corner shows two sides.

3. The frames will be lettered with capital letters, and no two frames will be assigned the same letter. InputEach input block contains the height, h (h<=30) on the first line and the width w (w<=30) on the second. A picture of the stacked frames is then given as h strings with w characters each.

Your input may contain multiple blocks of the format described above, without any blank lines in between. All blocks in the input must be processed sequentially.OutputWrite the solution to the standard output. Give the letters of the frames in the order they were stacked from bottom to top. If there are multiple possibilities for an ordering, list all such possibilities in alphabetical order, each one on a separate line. There will always be at least one legal ordering for each input block. List the output for all blocks in the input sequentially, without any blank lines (not even between blocks).Sample Input9

8

.CCC....

ECBCBB..

DCBCDB..

DCCC.B..

D.B.ABAA

D.BBBB.A

DDDDAD.A

E...AAAA

EEEEEE..Sample OutputEDABC

这道题主要是构图,要细心,很容易错

字典序输出

拓扑排序

没了

#include<iostream>
using namespace std;
#include<cstring>
#include<vector>
#include<algorithm>
#include<cstdio>

const int inf=0x3f3f3f3f;
const int maxn=35;
char a[maxn][maxn];
vector<int> vec[maxn];
int deg[maxn];
int n,m,all,maybe;
int posi[35][4];
int path[35];

void WORK() {
for(int i=0; i<maxn; ++i)vec[i].clear(),deg[i]=0;
memset(posi,inf,sizeof(posi));
for(int i=0; i<n; ++i) {
for(int j=0; j<m; ++j) {
if(a[i][j]!='.') {
posi[a[i][j]-'A'][0]=min(posi[a[i][j]-'A'][0],j);
posi[a[i][j]-'A'][1]=max(posi[a[i][j]-'A'][1]==inf?-1:posi[a[i][j]-'A'][1],j);
posi[a[i][j]-'A'][2]=max(posi[a[i][j]-'A'][2]==inf?-1:posi[a[i][j]-'A'][2],i);
posi[a[i][j]-'A'][3]=min(posi[a[i][j]-'A'][3],i);
}
}
}
memset(deg,0,sizeof(deg));
for(int i=0; i<26; ++i) {
if((maybe>>i)&1) {
int xmax=posi[i][2],xmin=posi[i][3],ymax=posi[i][1],ymin=posi[i][0];
//            cout<<"digit="<<" "<<ymin<<" "<<ymax<<" "<<xmin<<" "<<xmax<<endl;

for(int j=xmin; j<=xmax; ++j) {
char tc=a[j][ymin];
if(tc^(i+'A')) {
if(find(vec[i].begin(),vec[i].end(),tc-'A')==vec[i].end()) {

vec[i].push_back(tc-'A');
++deg[tc-'A'];
}
}
tc=a[j][ymax];
if(tc^(i+'A')) {
if(find(vec[i].begin(),vec[i].end(),tc-'A')==vec[i].end()) {
vec[i].push_back(tc-'A');
++deg[tc-'A'];
}
}
}
for(int j=ymin; j<=ymax; ++j) {
char tc=a[xmin][j];
if(tc^(i+'A')) {
if(find(vec[i].begin(),vec[i].end(),tc-'A')==vec[i].end()) {
vec[i].push_back(tc-'A');
++deg[tc-'A'];
}
}
tc=a[xmax][j];
if(tc^(i+'A')) {
if(find(vec[i].begin(),vec[i].end(),tc-'A')==vec[i].end()) {
vec[i].push_back(tc-'A');
++deg[tc-'A'];
}
}
}
}
}
//    for(int i=0; i<26; ++i) {
//        if((maybe>>i)&1) {
//            int len=vec[i].size();
//            printf("%c  ",i+'A');
//            for(int j=0; j<len; ++j) {
//                printf("%c",vec[i][j]+'A');
//            }
//            putchar(10);
//        }
//    }
}
/**
01234567
0 .CCC....
1 ECBCBB..
2 DCBCDB..
3 DCCC.B..
4 D.B.ABAA
5 D.BBBB.A
6 DDDDAD.A
7 E...AAAA
8 EEEEEE..
*/
void topSORT(int val) {
//    cout<<"val="<<val<<" all="<<all<<endl;
if(val>=all) {
for(int i=0; i<all; ++i) {
printf("%c",path[i]+'A');
}
putchar(10);
} else {
for(int i=0; i<26; ++i) {
if(((maybe>>i)&1)&&(!deg[i])) {
--deg[i];
int len=vec[i].size();
//                cout<<"i="<<i<<endl;
for(int j=0; j<len; ++j) {
--deg[vec[i][j]];
}
path[val]=i;
topSORT(val+1);
for(int j=0; j<len; ++j) {
++deg[vec[i][j]];
}
++deg[i];
}
}
}
}
int main() {
//    int uu=0;
//    uu|=(1<<('A'-'A'));
//    cout<<((uu>>(1))&1)<<endl;
#ifdef tangge
freopen("1128.txt","r",stdin);
#endif // tangge
while(~scanf("%d%d",&n,&m)) {
for(int i=0; i<n; ++i) {
scanf("%s",a[i]);
}
all=0;
maybe=0;
for(int i=0; i<n; ++i) {
for(int j=0; j<m; ++j) {
if(a[i][j]!='.'&&!((maybe>>(a[i][j]-'A'))&1)) {
maybe|=(1<<(a[i][j]-'A'));
++all;
}
}
}
//        for(int i=0;i<26;++i){
//            if((maybe>>i)&1){
//                cout<<(char(i+'A'));
//            }
//        }
//        cout<<endl;
WORK();
topSORT(0);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: