您的位置:首页 > 其它

Wolf and Rabbit

2016-07-20 10:05 387 查看
Description

There is a hill with n holes around. The holes are signed from 0 to n-1. 



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are
signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes. 

 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 

 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 

 

Sample Input

2
1 2
2 2

 

Sample Output

NO
YES

#include<stdio.h>

int GCD(int a,int b)

{
if(a%b==0)
return b;
else
return GCD(b,a%b);

}

int main()

{
int a,b,t,m,n,p;
scanf("%d",&p);
while(p--)
{
scanf("%d%d",&m,&n);
t=GCD(m,n);
if(t==1)
printf("NO\n");
else
printf("YES\n");
}

       return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: