您的位置:首页 > 其它

hdoj 5499 SDOI 【结构体排序】

2016-07-19 21:40 162 查看

SDOI

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 912    Accepted Submission(s): 365


[align=left]Problem Description[/align]
The Annual National Olympic of Information(NOI) will be held.The province of Shandong hold a Select(which we call SDOI for short) to choose some people to go to the NOI.
n(n≤100)
people comes to the Select and there is m(m≤50)
people who can go to the NOI.

According to the tradition and regulation.There were two rounds of the SDOI, they are so called "Round 1" and "Round 2", the full marks of each round is
300.

All the n people take part in Round1 and Round2, now the original mark of every person is known. The rule of SDOI of ranking gets to the "standard mark". For each round there is a highest original mark,let's assume that is
x.(it
is promised that not all person in one round is 0,in another way,x>0).
So for this round,everyone's final mark equals to his/her original
mark∗(300/x).

After we got everyone's final mark in both round.We calculate the Ultimate mark of everyone as
0.3∗round1′s
final mark + 0.7∗round2′s
final mark.It is so great that there were no two persons who have the same Ultimate mark.

After we got everyone's Ultimate mark.We choose the persons as followed:

To encourage girls to take part in the Olympic of Information.In each province,there has to be a girl in its teams.

1. If there is no girls take part in SDOI,The boys with the rank of first m enter the team.

2. If there is girls, then the girl who had the highest score(compared with other girls) enter the team,and other(boys and other girls) m-1 people with the highest mark enter the team.

Just now all the examination had been finished.Please write a program, according to the input information of every people(Name, Sex ,The original mark of Round1 and Round2),Output the List of who can enter the team with their Ultimate mark decreasing.

 

[align=left]Input[/align]
There is an integer T(T≤100)
in the first line for the number of testcases and followed
T
testcases.

For each testcase, there are two integers n
and m
in the first line(n≥m),
standing for the number of people take part in SDOI and the allowance of the team.Followed with
n
lines,each line is an information of a person. Name(A string with length less than
20,only
contain numbers and English letters),Sex(male or female),the Original mark of Round1 and Round2 (both equal to or less than
300)
separated with a space.

 

[align=left]Output[/align]
For each testcase, output "The member list of Shandong team is as follows:" without Quotation marks.

Followed m
lines,every line is the name of the team with their Ultimate mark decreasing.
 

[align=left]Sample Input[/align]

2
10 8
dxy male 230 225
davidwang male 218 235
evensgn male 150 175
tpkuangmo female 34 21
guncuye male 5 15
faebdc male 245 250
lavender female 220 216
qmqmqm male 250 245
davidlee male 240 160
dxymeizi female 205 190
2 1
dxy male 300 300
dxymeizi female 0 0

 

[align=left]Sample Output[/align]

The member list of Shandong team is as follows:
faebdc
qmqmqm
davidwang
dxy
lavender
dxymeizi
davidlee
evensgn
The member list of Shandong team is as follows:
dxymeizi

Hint
For the first testcase: the highest mark of Round1 if 250,so every one's mark times(300/250)=1.2, it's same to Round2.
The Final of The Ultimate score is as followed
faebdc 298.20
qmqmqm 295.80
davidwang 275.88
dxy 271.80
lavender 260.64
dxymeizi 233.40
davidlee 220.80
evensgn 201.00
tpkuangmo 29.88
guncuye 14.40

For the second testcase,There is a girl and the girl with the highest mark dxymeizi enter the team, dxy who with the highest mark,poorly,can not enter the team.

 
按题意先算出每个人的分数(在这儿出了小错),选拔要求:
1)没有女生,输出分数较高的m个人;
2)有女生,女生之中最高的一定输出,再输出其他男女生中m-1个分数较高的人
ps:
很多时候自己并不是不能做对,多一点自信,相信自己的思路是对的,可能就是某一处出了小问题,大的方向还是对的.

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct Node
{
char name[30];
char sex[10];
double r1,r2;
double score;
}stu[110];
int cmp1(Node a,Node b)
{
return a.r1>b.r1;
}
int cmp2(Node a,Node b)
{
return a.r2>b.r2;
}
int cmp3(Node a,Node b)
{
return a.score >b.score;
}
int main()
{
int t,n,m,i,j,f,f1,k;
double m1,m2;
char s[10]="female";
scanf("%d",&t);
while(t--)
{
f=0;
f1=0;
scanf("%d%d",&n,&m);
if(!m)
continue;
for(i=1;i<=n;i++)
{
scanf("%s %s",stu[i].name,stu[i].sex);
getchar();
scanf("%lf%lf",&stu[i].r1,&stu[i].r2);
}
//两个cmp连用只有最后一个有效
sort(stu+1,stu+n+1,cmp1);
m1=300.0/stu[1].r1;// 300/最大r1值
sort(stu+1,stu+n+1,cmp2);
m2=300.0/stu[1].r2;//300/最大r2值
for(i=1;i<=n;i++)
stu[i].score=0.3*m1*stu[i].r1+0.7*m2*stu[i].r2;
sort(stu+1,stu+n+1,cmp3);
printf("The member list of Shandong team is as follows:\n");
//以下是选拔分析!!
for(i=1;i<=n;i++)
{
if(strcmp(stu[i].sex,"female")==0)
{
f=1;k=i;break;
}
}
if(f)
{
if(k<=m)
{
for(i=1;i<=m;i++)
{
printf("%s\n",stu[i].name);
}
}
else
{
for(i=1;i<m;i++)
{
printf("%s\n",stu[i].name);
}
printf("%s\n",stu[k].name);
}
}
else
{
for(i=1;i<=m;i++)
{
printf("%s\n",stu[i].name);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: