您的位置:首页 > 其它

The MAX(sort) hd 1803

2016-07-19 17:59 155 查看
Description

Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F.



Input

Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2....Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed.

Output

For each test case, output the biggest value of F you can find on a line.

Sample Input

2

1 2

0

Sample Output

4017

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
bool cmp(int a,int b)
{
return a>b;
}
int main()
{
int n;
long long int a[110];
while(scanf("%d",&n)!=EOF)
{
if(n==0) break;
long long int sum=0;
for(int i=0;i<n;i++)
scanf("%lld",&a[i]);
sort(a,a+n,cmp);
sum=a[0]*(2010-n);
for(int i=1;i<n;i++)
sum+=a[i];
printf("%lld\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: