您的位置:首页 > 其它

HDOJ 1084 What Is Your Grade?

2016-07-19 16:32 423 查看

What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10630    Accepted Submission(s): 3299


[align=left]Problem Description[/align]
“Point, point, life of student!”

This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.

There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only
when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.

Note, only 1 student will get the score 95 when 3 students have solved 4 problems.

I wish you all can pass the exam!

Come on!

 

[align=left]Input[/align]
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed
time). You can assume that all data are different when 0<p.

A test case starting with a negative integer terminates the input and this test case should not to be processed.

 

[align=left]Output[/align]
Output the scores of N students in N lines for each case, and there is a blank line after each case.

 

[align=left]Sample Input[/align]

4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1

 

[align=left]Sample Output[/align]

100
90
90
95

100

 

[align=left]Author[/align]
lcy
 

……一开始看错了一句很重要的话(做了同样多题目得人数量半数以上能的 X5 分,这句话),WA了几次。

不是很难,看代码应该就能懂,所以就不写题解了。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct Stu
{
int ans,g,id;
char ti[25];
}a[111];
bool cmp1(Stu a,Stu b)
{
if(a.ans!=b.ans)
return a.ans>b.ans;
return strcmp(a.ti,b.ti)<0;
}
bool cmp2(Stu a,Stu b)
{
return a.id<b.id;
}
int main()
{
int n,i;
while(scanf("%d",&n)&&n!=-1)
{
int s1,s2,s3,s4;
s1=s2=s3=s4=0;
for(i=0;i<n;i++)
{
scanf("%d%s",&a[i].ans,a[i].ti);
a[i].id=i;
if(a[i].ans==4) s4++;
if(a[i].ans==3) s3++;
if(a[i].ans==2) s2++;
if(a[i].ans==1) s1++;
}
sort(a,a+n,cmp1);
int p,q,r,s;
p=q=r=s=0;
for(i=0;i<n;i++)
{
if(a[i].ans==5)
a[i].g=100;
if(a[i].ans==4)
{
if(p<s4/2)
{
a[i].g=95;
p++;
}
else
a[i].g=90;
}
if(a[i].ans==3)
{
if(q<s3/2)
{
a[i].g=85;
q++;
}
else
a[i].g=80;
}
if(a[i].ans==2)
{
if(r<s2/2)
{
a[i].g=75;
r++;
}
else
a[i].g=70;
}if(a[i].ans==1)
{
if(s<s1/2)
{
a[i].g=65;
s++;
}
else
a[i].g=60;
}
if(a[i].ans==0)
a[i].g=50;
}
sort(a,a+n,cmp2);
for(i=0;i<n;i++)
printf("%d\n",a[i].g);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: