您的位置:首页 > 其它

HDU 1492 The number of divisors(约数) about Humble Numbers (约数个数)

2016-07-19 14:59 405 查看

The number of divisors(约数) about Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3368    Accepted Submission(s): 1653


[align=left]Problem Description[/align]
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

[align=left]Input[/align]
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.

[align=left]Output[/align]
For each test case, output its divisor number, one line per case. 
[align=left]Sample Input[/align]

4
12
0

[align=left]Sample Output[/align]

3
6

[align=left]Author[/align]
lcy
[align=left]Source[/align]
“2006校园文化活动月”之“校庆杯”大学生程序设计竞赛暨杭州电子科技大学第四届大学生程序设计竞赛
[align=left]Recommend[/align]
LL   |   We have carefully selected several similar problems for you:  1496 1999 1798 1593 1722 

题解 :分解质因数:
   如果一个数分解质因数的形式是:M = 2^a * 3^b * 5^c * 7^d 。
    则M的约数个数 = (a+1)(b+1)(c+1)(d+1)。

AC代码:
#include<stdio.h>
#include<iostream>
typedef long long LL;
using namespace std;

int main()
{
LL n;
LL a[4];
while(cin>>n,n)
{
for(a[0]=0;n%2==0; n/=2)
{
a[0]++;
}
for(a[1]=0; n%3==0; n/=3)
{
a[1]++;
}
for(a[2]=0;n%5==0;n/=5)
{
a[2]++;
}
for(a[3]=0; n%7==0;n/=7)
{
a[3]++;
}
int sum=(a[0]+1)*(a[1]+1)*(a[2]+1)*(a[3]+1);
cout<<sum<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: